What is this? From this page you can use the Social Web links to save Error GPG al actualizar repositorios to a social bookmarking site, or the E-mail form to send a link via e-mail.

Social Web

E-mail

E-mail It
abril 01, 2010

Error GPG al actualizar repositorios

Posted in: Linux

A veces se produce un error de GPG de verificación de llave pública al actualizar un ordenador con linux debian o compatible (apt-get update).
Se ha mejorado el sistema de seguridad de verificación de paquetes y este error aparece cuando la clave pública ha caducado.
La solución está en ejecutar las dos instrucciones siguientes para importar la nueva clave:

gpg --keyserver subkeys.pgp.net --recv-keys XXXXXXXXXXXXXXXX
gpg --armor --export XXXXXXXXXXXXXXXX | sudo apt-key add -

(Hay que sustituir XXXXXXXXXXXXXXXX por la clave pública que nos indica el mensaje de error)

Si esto no funciona se puede probar a actualizar los ficheros de llaves con:

apt-get install debian-keyring debian-archive-keyring


Return to: Error GPG al actualizar repositorios

//